Nav bar not working

Avatar
  • updated
  • Answered
   I have just attempted to renew my website, which is based on a template and includes a Nav Bar from Spry Assets.  The new Home Page looks OK but when I click on the options on the NavBar, e.g. Home, the page reverts to the old webpages.  What could be going wrong?  To see this effect click on www.captum.com

Avatar
Arnel C

Hello Michael,

Thanks for your perseverance!  I know that this kind of work can be frustrating.  The biggest headache when working with different systems is keeping with certain rules for files  - particularly naming conventions.  For example, web files don't do well when you put a space in the name.  So, you should be using file names like this:  example_file.htm or examplefile.htm .   I use no spaces.  Additionally, as this is a linux-based backend (CentOS) - the server recognizes differences in case.  So, if you have file named EXAMPLE.htm and a file named example.htm - they would be 2 different files.  For simplicity's sake, I recommend not using any spaces in file names and keeping everything lower case. If you want to learn more about it, check out this site.  

Just to explain, I decided to take a close look at your site files.  This is something that our live support would normally do with you.  The live support team is a 24/7 operation and a totally different group. The NAV BAR is generally a jumping point that points to different files  from one location to another (either a file or a URL). It's also often called a MENU BAR or MENU. When I looked at it, I looked at what could be seen in the browser just by hovering over the different NAV BAR items. You can see what the NAV BAR is supposed to jump to without actually clicking on it - generally, the URL appears at the bottom of the browser. 

I compared the ones that you said were having issues and you may have done some work that cleaned up some of the problems.  Remember that you would need to clear your browser cache before looking at the page again in order to properly see your recent changes
Anyways, I can see almost every item working in your NAVBAR - the exception being EVENTS.







You can see in the screenshot above that it's basically just a white space.  I can see what's being sent to the browser by using the browser option called INSPECT (in the Firefox Browser).  This lets me see the code that's supposedly being read by the browser.

I could see that there is supposed to be a table loading with the different events.  But nothing is shown. This is when I began looking at your code and seeing the spaces and mixed case.  The server will automatically take spaces in a file name and replace them with "%20."  I did see at least one directory referenced in the code with the space in it.  This may be causing the table to break.  Or there could also be mismatched references to files in lower case and upper case names.  I'm not 100% sure if that is truly the cause, but I would start there.  It can be problematic if you continue to name the file names and directories like that.

Sorry for the long-winded explanation.  I hope it helps!  We unfortunately can't code or provide coding in support, but we can try to point out the issues that could be the source of a problem.  






Avatar
michael brand

Hi Arnel.  I did the file synch as you suggesed but it didn't help.  There is somehing very strange happening on this web site with the Nav Bar.  The first two entries (captum.com/ Home or MasterClass work they way they are supposed to, but the others don't (except Blog, which works in a different way).  I deleted the template file and Events from the remote site and reloaded them.  The events link worked - once!  When I clicked away from it to Home and clicked back to Events it had gone and I now get a 404.  I can't reproduce that behaviour.  Please let me know if you have any other ideas.  I'm ready to remake the template and reattach it to each file.   Thanks for the help, kind regards, Michael Brand

Avatar
Arnel C
Quote from michael brand
Hi Arnel.  Thanks for the suggestions and for staying with this problem.  The problem seems to be, at least in part, that when I try to upload new or revised files to the Public_html folder, it doesn't always work and the old files stay there.  I'll have another try today, and if that doen't work, I'll call the live technical support team, as you suggest.  Thanks for the  help and best regards, Michael Brand

Thanks for your reply Michael!  I hope that you are able to get the issue resolved.  I was looking at Adobe's Dreamweaver documentation out of curiosity and probably the best thing that would help is to take a look at the synchronization of files.  You want to sync the newer files to the server.  This is the link to their documentation.  I hope it helps!

If you have any further questions or comments, please let us know.


Kindest Regards,

Arnel C.

Avatar
michael brand
Hi Arnel.  Thanks for the suggestions and for staying with this problem.  The problem seems to be, at least in part, that when I try to upload new or revised files to the Public_html folder, it doesn't always work and the old files stay there.  I'll have another try today, and if that doen't work, I'll call the live technical support team, as you suggest.  Thanks for the  help and best regards, Michael Brand

Avatar
Arnel C
Quote from michael brand
Thanks for the  prompt answer.  It helped in part.  Look at captum.com - the first two Nav Bar items now work properly.  However, Events, Newsletter, Sensor100 and About US are still the old versions.  When I upload those files from Dreamweaver they don't seem to be on InMotion.  I've tried using the InMotion Upload function with the same result.  If you have any further ideas I would be very grateful.
Kind regards and thanks,
Michael Brand

Hello Michael,

Sorry for the frustration.  I'm not sure what settings you're using to upload the files from DreamWeaver to the InMotion server.  However, I would double-check to make sure that your most recent updates are replacing the files in the PUBLIC_HTML folder.  That is where your main website files are saved.  You can directly view the files on the server by logging into the cPanel, going to File Manager, then looking in the PUBLIC_HTML folder.  If those files are not being replaced, then the updates are not happening properly.  

It also looks like you have other domains on the account too.  If you look in cPanel under ADDON Domains, then you can see where the locations for those sites exist.  The PUBLIC_HTML folder is the default location for the primary site for the account.  I think you may be saving the updated files for that website into a different location.

You can use the cPanel File Manager to move the files to the right place.  If you need further assistance, then I recommend calling in to our live technical support team (or using chat).  They can walk you through moving the files into the correct locations. 

I hope that helps to clarify things and get it all working!  If you have any further questions or comments, please let us know.


Kindest Regards,

Arnel C.

Avatar
michael brand
Thanks for the  prompt answer.  It helped in part.  Look at captum.com - the first two Nav Bar items now work properly.  However, Events, Newsletter, Sensor100 and About US are still the old versions.  When I upload those files from Dreamweaver they don't seem to be on InMotion.  I've tried using the InMotion Upload function with the same result.  If you have any further ideas I would be very grateful.
Kind regards and thanks,
Michael Brand

Avatar
Arnel C
  • Answered

Thanks for the question concerning the renewal/redesign of your site.  Since you provided your domain name, I was able to use the Internet Archive - Wayback Machine to look at your site as it appears in 2021.  

When I look at your site on my browser I'm seeing a different menu - like the Bookstore no longer connects to Amazon. It is possible that your browser is using a cached version of your site. So you're only seeing what was saved in the cache - not the updates.  Clear your browser cache and then try it again. You can see how to clear a browser cache in our article:  How to Clear Browser Cache for Major Browsers.

If you have any further questions or comments, please let us know.


Kindest Regards,

Arnel C.