Python on shared reseller accounts/ launch plan

Avatar
  • updated
  • Answered

I have the Launch Plan. I checked the Python version that is installed. It is 2.6.6. Can we have python 2.7 installed ? Or even better, Python 3 ? Thanks !

Pinned replies
Avatar
Ronnie H.
  • Answer
  • Answered

Hi, Francois! Unfortunately, a good chunk of vital software that keeps cPanel, Apache, and CentOS all working together with each other is coded with the older versions of Python. The upgrade to 2.7 is likely, though I can't give you a timetable on it right now. 

Python 3 will not be available on the shared plans, though it can be installed on a VPS. If you get a VPS and install it yourself, just be sure to run it on a virtual machine! Trying to make Python 3 the 'default' version of Python on a VPS conflicts with those dependencies I mentioned above and causes all sorts of trouble. 

Avatar
Ronnie H.
  • Answer
  • Answered

Hi, Francois! Unfortunately, a good chunk of vital software that keeps cPanel, Apache, and CentOS all working together with each other is coded with the older versions of Python. The upgrade to 2.7 is likely, though I can't give you a timetable on it right now. 

Python 3 will not be available on the shared plans, though it can be installed on a VPS. If you get a VPS and install it yourself, just be sure to run it on a virtual machine! Trying to make Python 3 the 'default' version of Python on a VPS conflicts with those dependencies I mentioned above and causes all sorts of trouble.